Page tree
Skip to end of metadata
Go to start of metadata

Die nachfolgenden Inhalte stellen Sie unter Administration >  DatenImport ein.


1. Import von CSV Daten

Den CSV-Import nutzen Sie für den generellen Import von Daten in Listenform. Dabei können Sie auch bereits bestehende Datensätze aufgrund verschiedener Merkmale aktualisieren. Der Import ist momentan für die Module Kontakte, Accounts, Verträge, Tickets, Projekte, Ressourcen, Angebote, Aufträge, RechnungskontenKassenbuch-Einträge und Artikelverwaltung möglich. Sprechen Sie uns an, wenn Sie andere Daten über CSV-Dateien importieren möchten. Ein Import von strukturierten und verknüpften Daten ist nur begrenzt für die aufgeführten Module möglich und wird über verschiedene Imports realisiert. Weitere strukturierte Daten müssen zuvor Analysiert und abgeschätzt werden, wie die Daten effektiv und kosteneffizient übernommen werden können. Bei der Verwendung von Microsoft Excel lesen Sie bitte diesen Abschnitt, bevor Sie einen Import oder eine Aktualisierung Ihrer Daten vornehmen. 

Schrittfolge für den Datenimport

  1. Wählen Sie zuerst die zu importierende CSV-Datei auf Ihrem lokalen Laufwerk aus.
  2. In der Regel werden Daten innerhalb einer CSV-Datei automatisch mit  ; Semikolon getrennt. Sollten Sie eine andere Trennung, wie Tabulator  oder Komma  , nutzen, müssen Sie dies beim Zu importierenden Dateityp auswählen.
  3. Bei Felder eingeschlossen von brauchen Sie in der Regel nichts ändern. Diese Angabe bezieht sich auf Felder Ihrer CSV-Datei in der mehrere Daten in nur einem Feld eingetragen sind. Diese werden meistens auch mit ; Semikolon getrennt, müssen aber in " eingeschlossen werden, da sonst weitere Felder belegt würden.

    Feld1;Feld2;Feld3 ergibt Feld 1 = Feld1 | Feld 2 = Feld2 | Feld 3 = Feld3
    Feld1;"Feld2;Feld3" ergibt Feld 1 = Feld1 | Feld 2 = Feld2;Feld3

  4. Wählen Sie nun das Modul, für welches Sie Daten importieren möchten aus. Sollte Ihr Modul nicht aufgeführt sein, setzen Sie sich bitte mit unserem Support in Verbindung.
  5. Beim Modul Rechnungskonten kann zusätzlich eine Auswahl für den Mandanten zur Verfügung stehen. Wählen Sie diesen entsprechend aus.
  6. Unter Zugriffsrechte für neue Datensätze können Sie auswählen, welche Zugriffsliste während des Imports für die neuen Objekte gesetzt werden soll. Sollen Daten mit unterschiedlichen Rechten importiert werden, empfiehlt es sich entweder mehrere Imports mit unterschiedlichen Rechten oder ein Import aller Datensätze durchzuführen und später über die Massenbearbeitung im Modul selbst die Rechte neu zu setzen.
  7. Die Importart gibt die Art der Verwendung der Daten an. Neue Daten importieren und vorhandene aktualisieren durchsucht die Daten aufgrund verschiedener Merkmale (Daten aktualisieren). Nur neue Daten importieren - vorhandene werden nicht geändert nutzen Sie meistens für den nachträglichen Import neuer Daten, um die von Ihnen gepflegten Daten nicht zu ändern. Möchten Sie generell neu beginnen, nutzen Sie die Option Alle Daten löschen und neue importieren. Dabei gehen alle Verknüpfungen bestehender Daten im TecArt-System verloren. Bei dieser Variante haben Sie die Option Sicheres Löschen. Aktivieren Sie diese, so werden die Daten in den globalen Papierkorb verschoben. Ist diese Option nicht aktiviert, werden die Daten direkt aus der Datenbank gelöscht und können nicht wiederhergestellt werden.
  8. Gegebenenfalls müssen Sie noch den Importzeichensatz anpassen. Dieser sollte in der Regel auf iso-8859-1 stehen und enthält die deutschen Zeichen. Dies richtet sich aber auch nach den verwendeten Zeichensätzen Ihres Programms, mit dem Sie die CSV-Datei erstellt haben. Weitere Hinweise hierzu finden Sie auf der Webseite http://de.wikipedia.org/wiki/ISO_8859-1
  9. Mit Klick auf Weiter starten Sie den Dateiupload und gelangen zum nächsten Fenster.
 

Vor dem Import müssen Sie für neue Objekte entsprechende Rechte in den Zugriffslisten einstellen und die zu verwendenden Rechte als Standard im entsprechenden Modul (z. B. Moduleinstellungen für Kontakte und Personen) festlegen. Sollen die zu importierenden Daten unterschiedliche Rechte erhalten, können Sie die Datensätze teilen und jeweils andere Standardzugriffsrechte beim Importdialog festlegen.

Im nun folgenden Abschnitt weisen Sie Ihre Daten der jeweiligen Spalte Ihrer CSV-Datei einem Feld innerhalb des TecArt-System zu. Dies machen Sie, indem Sie jeweils eine Feldbezeichnung im Fenster CSV Felder und ein Feld des TecArt-Systems im Fenster System Felder markieren und in der Mitte der Zuordnungsfenster den Button > drücken. Nun ist auf der linken Seite das bereits verwendete Feld ausgegraut und mit dem Feld des TecArt-Systems verbunden. (z.B. Kontakt - Nummer -> Nummer)

Dies wiederholen Sie so oft, bis Sie alle gewünschten Felder zugeordnet haben. Eine fehlerhafte Feldzuordnung können Sie lösen, wenn Sie im Feld  System Felder den Eintrag markieren und auf  Zuordnung löschen klicken. Alle Zuordnungen löschen entfernt alle gesetzten Zuordnungen.

 

Haben Sie zuvor einen Export gemacht oder haben Sie Ihre Spaltenüberschriften in der CSV-Datei entsprechend der Feldbezeichnungen im TecArt-System angepasst, so können Sie mit dem Klick auf den Button Standardzuordnung Ihre Felder schnell automatisch zuordnen. Ausgegraute Felder konnten zugeordnet werden, dennoch sollten Sie nun unbedingt auf der rechten Seite die Zuordnungen überprüfen.

Eindeutig ist eine Zuordnung z.B. von Kontakt - Nummer zu Kontakt - Nummer. Es kann aber auch vorkommen, dass z.B. Ihre Spalte Nummer gleichzeitig zu Kontakt - Nummer und Person - Nummer zugeordnet wird. In diesem Fall müssen Sie ggf. die Zuordnung löschen.


Bevor Sie nun mit dem Import Ihrer Daten starten können, müssen Sie unbedingt die Dublettenprüfung für den Import einstellen. Dies ist zwingend erforderlich und ist unabhängig von einer eingestellten Dublettenprüfung innerhalb des Moduls.

Markieren Sie in dem sich öffnenden Fenster alle Felder, die für diesen Import eine Dublette darstellen. Dies ist nicht nur für die Aktualisierung entscheidend, sondern sortiert ggf. auch doppelte Datensätze bei Neuimporten aus und vermeidet so Inkonsistenzen.

Über den Button Vorschau öffnet sich ein neues Fenster. In diesem erhalten Sie eine Vorschau für den Import und können einsehen, ob die Daten der CSV-Datei auch in die richtigen Felder des TecArt-Systems eingespielt werden würden. Ist dies der Fall können Sie die Vorschau schließen und den Import mittels Importieren starten. Den aktuellen Import-Status sehen Sie anhand der folgenden Fortschrittsanzeige. Am Ende des Imports wird Ihnen ein Importbericht ausgegeben.

 

Importiert werden nur Daten in Felder, welche zum Zeitpunkt des Imports nicht schreibgeschützt sind. Diese Einstellung nehmen Sie in der Felderverwaltung vor. Nach dem Import können Sie diese Felder gern wieder schützen.

Sollten eine Vielzahl von Datensätzen nicht importiert bzw. aktualisiert werden können, bricht das System automatisch ab.

 

Über die Button Zurück und  Weiter im Bereich Ihrer Daten, können Sie die Datensätze vor dem Import betrachten und sehen die entsprechenden Ergebnisse im Bereich der Systemfelder.

1.1. Import von Pflichtfeldern

Möchten Sie beispielsweise Ihre bestehenden Artikel aus Ihrer Warenwirtschaft in das TecArt-System importieren, ist auf die jeweiligen Pflichtfelder im TecArt zu achten. Daten werden in das System nur importiert, wenn alle notwendigen Pflichtfelder in der CSV-Datei angegeben worden. Dies gilt als Sicherheit, damit wichtige Daten beim Import nicht vergessen werden. Bei den Artikeln ist ein Pflichtfeld die Mehrwertsteuer respektive Umsatzsteuer. Pflichtfelder können natürlich auch für alle anderen Module festgelegt werden. Weitere Informationen hierzu finden Sie in der Felderverwaltung

1.2. Neuimport von mehreren Personen zu einem Kontakt

Möchten Sie mehrere Personen zu einem Kontakt importieren, so ist es wichtig, dass der Aufbau Ihrer CSV-Datei korrekt ist, damit das TecArt-System bestehende Dubletten erkennt bzw. weiß welche Person zu welchem Kontakt gehört. Grundlegend empfehlen wir für die bessere Übersichtlichkeit sich eine entsprechende Kopfzeile anzulegen, beispielsweise Firma, Adresse, PLZ, Ort, Vorname und Nachname. Je nachdem welche Kontakt- oder Personendaten Sie importieren möchten, können Sie die CSV-Datei mit weiteren Spalten erweitern. Unter dieser Kopfzeile tragen Sie dann die jeweiligen Daten ein, welche ins TecArt-System importiert werden sollen. Beim späteren Import ist es dabei wichtig, die Option Ersten Datensatz überspringen anzuwählen, da ansonsten versucht wird, die Daten der Kopfzeile mit zu importieren. 

 

Möchten Sie eine CSV-Vorlage für die Aufbereitung der Daten und den späteren Import nutzen, so führen Sie einen Export über das Kontextmenü durch. Blenden Sie sich vorher die gewünschten Spalten ein.

Sollen nun mehrere Personen zu einem Kontakt importiert werden, so ist es wichtig, dass die Firmenbezeichnung und Adressdaten des Kontakts identisch sind, damit das System eine Zuordnung der Person zum Kontakt vollziehen kann. Rechts sehen Sie die korrekte Struktur der CSV-Datei, damit Personen zum gleichen Kontakt importiert und nicht mehrere Kontakte angelegt werden. Wichtig ist außerdem, dass Sie beim Import eine Dublettenprüfung festlegen. Hierbei können Sie beispielsweise die Felder Firma, Adresse, Ort und PLZ sowie bei den Personenfeldern den Nachnamen wählen.

1.3. Daten aktualisieren

Möchten Sie Datensätze nur aktualisieren, empfehlen wir Ihnen lediglich mit dem Nummernfeld (realnumber) und den zu aktualisierenden Datenfelden zu arbeiten. Überprüfen können Sie für jeden Import zuerst diese Nummer mit Hilfe der Dublettenprüfung. Stimmt die Nummer mit einer Nummer eines Objektes in Ihrem TecArt-System überein und haben Sie die Auswahl Neue Daten importieren und vorhandene aktualisieren gewählt, werden alle zugeordneten Felder mit den Daten aus Ihrer CSV-Datei überschrieben. Das Nummernfeld stellt dabei ein eindeutiges Merkmal dar.

1.3.1. Aktualisierung von Kontakten

Für die Aktualisierung von Kontakten benötigen Sie das lediglich das Nummernfeld sowie die zu aktualisierenden Daten. Möchten Sie z. B. das Feld Umsatz für einige Kontakte aktualisieren, werden nur die Felder Kontakt - Nummer und Kontakt - Umsatz verknüpft. Dabei werden die Daten des Umsatzfeldes mit den Daten aus Ihrer CSV-Datei überschrieben.

 

Eine Aktualisierung der Kontaktnummer ist über das Einspielen einer CSV-Datei nicht möglich.

1.3.2. Aktualisierung von Personen

Für die Aktualisierung von Personen benötigen Sie die Kontakt-Nummer, den Vornamen und Nachnamen der Person sowie die zu aktualisierenden Daten. Möchten Sie z. B. das Feld Newsletter für einige Personen aktualisieren, werden nur die Felder Kontakt - Nummer, Person - Vorname, Person - Nachname und Person - Newsletter verknüpft. Dabei werden die Daten des Newsletterfeldes mit den Daten aus Ihrer CSV-Datei überschrieben. 

 

Die Wahrscheinlichkeit, dass in einem Kontakt mehrere Personen den gleichen Namen besitzen ist sehr gering. Sind in einem Kontakt mehrere Personen mit demselben Vor- und Nachnamen vorzufinden, erhalten beide Personen die Angabe aus der CSV-Datei. Dabei werden die zuletzt importierten Daten der CSV-Datei gesetzt.

1.4. Einstellbare Dublettenprüfung

Sollten Sie ohne das Nummernfeld Ihrer Objekte arbeiten oder die Nummer nicht wissen, werden während des Imports, die in der Dublettenprüfung eingestellten Felder überprüft. Alle hier markierten Felder müssen exakt übereinstimmen, damit es sich um eine Dublette handelt. Je mehr Felder Sie angeben, um so aufwendiger und genauer ist die Prüfung zum Auffinden von Dubletten. Wir empfehlen jedoch immer den Import anhand einer eindeutigen Nummer zu vollziehen. Bei dem Modul Kontakte muss beispielsweise immer die Nummer oder zumindest eine Firmenbezeichnung für die Dublettenprüfung herangezogen werden, wenn Sie beim Import neue Daten importieren und ggf. vorhandene aktualisieren möchten.

1.5. Hinweise für die Datenangaben in Ihrer CSV-Datei

Einige Daten aus Ihrer CSV-Datei müssen besonders aufbereitet werden, damit diese importiert werden können. Die Ausgabe von Daten kann vom Import abweichen. Hintergrund ist die Verarbeitung der Daten für Ihre Benutzer und in der Datenbank. So können Ihre Benutzer nichts mit den Angaben 0 oder 1 anfangen, wenn die Person einen Newsletter erhalten soll oder eben nicht. In einem Export dieser Daten werden die Angaben zu Nein für 0 und Ja für 1. Ähnlich verhält es sich für die Art der Speicherung der Daten, welche Sie in der Felderverwaltung angegeben haben.

FeldtypDatenanzeigeCSV-Datei
KontrollkästchenJa
Nein
1
0
Drop-Down-Liste mit Listenwert=IndexTecArt CRM Professional Cloud
TecArt CRM Professional Server
1
2
Drop-Down-Liste mit Listenwert=WertTecArt CRM Professional Cloud
TecArt CRM Professional Server
TecArt CRM Professional Cloud
TecArt CRM Professional Server
Drop-Down-Liste der Liste Benutzer mit Angabe der Benutzer-IDGoldschmied, Anne
Müller, Franz
8
2
Drop-Down-Liste MehrfachauswahlTecArt CRM Professional Cloud
TecArt CRM Professional Server
"TecArt CRM Professional Cloud;TecArt CRM Professional Server"

Die Werte müssen in Zeichen (z. B. ") eingeschlossen werden. Dies sollte Ihr Programm (z.  B. MS Excel) automatisch machen.

Verknüpfungsfeld (Kontaktsauswahl, Projektauswahl etc.TecArt GmbH
Adam Wies - Privatschule am Dom
65
79
Für die Zuordnung der Objektverknüpfung ist es notwendig die Objekt-ID anzugeben. Diese Information erhalten Sie in jedem Objekt rechts oben neben der Hilfe.

1.6. Fehler und Lösungen

1.6.1. Import-Zusammenfassung zeigt 0 importierte/aktualisierte/übersprungene Datensätze

Beim Import von Kontakten kann es vorkommen, dass der Vorgang beendet wurde und in der Zusammenfassung angezeigt wird, dass 0 Datensätze importiert, aktualisiert und übersprungen wurden.

Dieser Fall kann eintreten, wenn beim Import von Kontaktdaten für das Feld Firma keine Daten vorhanden sind. Das System prüft demzufolge beim Import, ob eine Zuordnung anhand des Firmenfeldes möglich ist. Ist dieses leer, so versucht das System anhand von "Nachname" und "Vorname" eine Zuordnung zur Firma herzustellen. Hierbei wird der Firmenname mit der Eintragung "Nachname, Vorname" abgeglichen. Ist nur eines der beiden Felder vergeben worden, wird ebenfalls gesucht, ob der angegebene Wert im Firmenfeld zu finden ist.

Daher muss sowohl beim Neuimport als auch der Aktualisierung von Kontaktdaten immer ein Firmenfeld, Nachname oder Vorname vorhanden sein. 

2. VCard-Import

Den Import von VCF-Dateien können Sie über diese Registerkarte vornehmen. Dabei wählen Sie über Datei hochladen einzelne .vcf Dateien aus oder nutzen die Möglichkeit mehrere .vcf Dateien in einer ZIP-Datei zusammenzufassen.

Der Datenimport funktioniert so, dass beim Import der Firmenname überprüft wird. Stimmt dieser mit dem Firmennamen eines anderen Kontaktes überein, handelt es sich um ein Duplikat. Mehrere Personen eines selben Unternehmens werden dementsprechend unter derselben Firma angelegt. Andernfalls wird eine neue Firma mit der neuen Person angelegt.

3. Datenimport aus Outlook

Sofern Ihr aktuelles Microsoft Produkt den Export von Kontaktdaten via CSV-Dateien anbietet, so wäre der anschließende Import auch über diesen Dateityp zu empfehlen. Darüber hinaus stellen wir Ihnen einen TecArt CRM Outlook Importer zur Verfügung, mit welchem Sie Aufgaben und Termine importieren können. Auch der Import von Kontakten wäre möglich.

4. Import einer bereits gesicherten TecArt-Datenbank

Hier können Sie bereits vorhandene Datenbank-Sicherungen, die Sie aus dem TecArt-System exportiert haben, wieder über  Datei hochladen in das System übernehmen. Über Weiter werden alle Daten der aktuellen Datenbank durch die gesicherte Datenbank überschrieben.

 

Eine selektive Datenrückspielung ist über diese Methode nicht möglich. Die Einspielung der kompletten Datenbank überspielt alle Informationen, jedoch keine E-Mails und Dokumente. Es kann jedoch vorkommen, dass Datensätze zu nicht mehr vorhandenen E-Mails und Dokumenten noch vorhanden sind.
Die Rückspielung setzt alle Daten auf den Stand der Datensicherung zurück. Dies sind Daten der Benutzer, Rechte und Passwörter der Benutzer, Objekte, Termine, Aufgaben, Notizen, Anzeigen, persönliche Einstellungen etc.

Bitte wenden Sie sich im Fall einer gezielten Datenrückspielung immer an die Mitarbeiter unseres Supports.

5. Der korrekte Workflow und wichtige Hinweise bei der Verwendung von Microsoft Excel

5.1. Zeichensatz und Export der Daten aus dem TecArt-System

Für den Export der Daten sind vorher einige Einstellungen zu prüfen. In Ihren persönlichen Einstellungen geben Sie an, in welchem Zeichensatz-Format die CSV-Datei gespeichert werden soll. Die exportierte Datei muss dann später über das entsprechende Programm im gleichen Zeichensatz geöffnet werden, ansonsten gibt es Probleme mit der Darstellung bzw. Übersetzung der Zeichen. Bei Verwendung des Export-Moduls können Sie alle Kontakt- und Personendaten über die Exportfunktion extrahieren.

5.2. Import von CSV-Dateien in Microsoft Excel

Befindet sich Ihre Datei beispielsweise im Format UTF-8, so ist es erforderlich, die Datei in diesem Format auch zu importieren. Eine automatische Erkennung seitens Microsoft Excel ist nicht immer möglich, weshalb Sie die Importfunktion in Excel nutzen müssen. Hierfür führen Sie bitte folgende Schritte aus.

5.2.1. Office 2010 bis 2016

https://support.office.com

  • Öffnen Sie Microsoft Excel.
  • Wählen Sie die Registerkarte Daten >Abschnitt Externe Daten abrufen > Aus Text.
  • Klicken Sie nun auf den Punkt Getrennt, wählen Sie bei Dateiursprung das entsprechende Format, in dem Ihre CSV-Datei vorliegt. In unserem Fall nehmen wir den Datensatz UTF-8. Wählen Sie nun weiter.
  • Im nächsten Schritt klicken Sie auf Semikolon und entfernen den Haken bei "Tabstopp", damit die Formatierung der Spalten korrekt vollzogen wird.
  • Als letztes klicken Sie auf weiter und verändern ggf. je Spalte den Importtyp, anschließend auf fertig stellen.
  • Die Daten werden Ihnen nun im korrekten Format angezeigt, ohne Formatierungs- oder Umlautfehler.

5.2.2. Office 365

https://support.office.com

  • Öffnen Sie Microsoft Excel.
  • Wählen Sie die Registerkarte Daten >Abschnitt Optionen > Daten.
  • Klicken Sie nun unter Assistenten für Legacy-Datenimport anzeigen die Option aus Text (Legacy) aus.
  • Folgen Sie nun den weiteren Anweisungen, wie oben beschrieben.

5.2.3. Weitere Hinweise

Möchten Sie Ihre Datei speichern, navigieren Sie zu Datei > Speichern unter und wählen Sie bei Dateityp CSV (Trennzeichen-getrennt)

Sollten sich Daten nach den Import von Microsoft Excel in den falschen Spalten befinden oder werden Umlaute nicht korrekt angezeigt, so haben Sie die Möglichkeit beim Microsoft Importdialog andere Optionen (Zeichensatz, Trennungszeichen) zu setzen. 

6. Weitere Seiten zu Import